Checks whether the given drawing is up-to-date.
GSErrCode ACAPI_Database ( APIDb_CheckDrawingStatusID, const API_Guid* guid, Int32* status );
Parameters
- guid
- [in] The GUID of the drawing element
- status
- [out]
1
if the drawing is up-to-date,0
if modified,-1
otherwise
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
status
parameter isnullptr
, or the drawing contains invalid link ID. APIERR_BADINDEX
- The
guid
is not valid, or the drawing comes from a master layout.
For other common API errors see the API Errors document.
Remarks
Call this function to check the status of a drawing quickly (as seen on the Drawing Link Manager palette).
Requirements
- Version: API 10 or later
- Header: APIdefs_Database.h