APIDb_​CheckWindowValidatorID

Cheks the already added list of elements and checksums form the validator (identified by the guid) against the lists from the parameter if there was any changes.

    GSErrCode ACAPI_Database (
        APIDb_CheckWindowValidatorID,
        const API_WindowValidatorInfo*   pValidatorInfo,
        bool*                            pContentChanged

    );

 

Parameters

pValidatorInfo
Contains the guid of a window which is the owner of the validator and the current, and the element and checksum list to check against.
pContentChanged
Out paramter for the result. true if there was a change false otherwise.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
pValidatorInfo or pContentChanged is nullptr
APIERR_MEMFULL
Not enough memory to complete the operation.
APIERR_GENERAL
There is no validator registered for this guid.

For other common API errors see the API Errors document.

 

Remarks

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database
API Functions