APIDb_​CreateSubSetID

Creates the Subset in the Layout Book.

    GSErrCode ACAPI_Database (
        APIDb_CreateSubSetID,
        const API_SubSet*     subSet,
        const API_Guid*       parentGuid
    );

 

Parameters

subSet
The Subset.
parentGuid
The guid of parent node in the Navigator’s Layout Map

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
parentGuid is nullptr
APIERR_MEMFULL
Not enough memory to complete the operation.

For other common API errors see the API Errors document.

 

Remarks

You can create subsets in the Layout Book with this function. You are able to get the default SubSet Settings via APIDb_GetSubSetDefaultID database function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database
API Functions