Returns the next element’s guid
from the previously initialized creation order table.
GSErrCode ACAPI_Database ( APIDb_CreationOrderGetNextID, API_Guid* guid );
Parameters
- guid
- [in/out] On input this is the
guid
of the element for which the following in creation order is sought. On output this is theguid
of the following element.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
guid
parameter is nullptr. APIERR_GENERAL
- The creation order table was not allocated beforehand.
APIERR_NOMORE
- The
guid
parameter is not in the table or it was the last elem.
For other common API errors see the API Errors document.
Remarks
This function is used to get the next element’s guid
in element creation order. Input a value of APINULLGuid
to get the first element; an output value of APINULLGuid
means the last elem. The creation order table must be initialized beforehand with APIDb_InitCreationOrderTableID.
Example
See the example at APIDb_InitCreationOrderTableID.
Requirements
- Version: API 11.01 or later
- Header: APIdefs_Database.h
See Also
ACAPI_Database, APIDb_InitCreationOrderTableID, APIDb_DisposeCreationOrderTableID, API_Guid, API Functions