Deletes the given hotlink node.
GSErrCode ACAPI_Database ( APIDb_DeleteHotlinkNodeID, const API_Guid* hotlinkNodeGuid );
Parameters
- hotlinkNodeGuid
- [in]
guid
of the hotlink node to be deleted
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
hotlinkNodeGuid
parameter isnullptr
.APIERR_BADID
hotlinkNodeGuid
is invalid.APIERR_NEEDSUNDOSCOPE
- The function must be undoable, it wasn’t called from an undoable command scope.
For other common API errors see the API Errors document.
Remarks
This function deletes the hotlink node identified by the hotlinkNodeGuid
parameter. Unlike APIDb_BreakHotlinkNodeID all the instance elements created from this node are removed from the project.
Requirements
- Version: API 12 or later
- Header: APIdefs_Database.h
See Also
API_HotlinkNodeAPIDb_GetHotlinkNodeID
APIDb_CreateHotlinkNodeID
APIDb_ModifyHotlinkNodeID
APIDb_BreakHotlinkNodeID
ACAPI_Database
API Functions