APIDb_​DestroyWindowValidatorID

Destroys an already registered validator for the given guid.

    GSErrCode ACAPI_Database (
        APIDb_DestroyWindowValidatorID,
        const API_Guid*     pGuid
    );

 

Parameters

pGuid
The guid of the owner window of the validator.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
pValidatorInfo is nullptr
APIERR_MEMFULL
Not enough memory to complete the operation.
APIERR_GENERAL
There is no validator registered for this guid.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database
API Functions