Shows/draws an existing element.
GSErrCode ACAPI_Database ( APIDb_DrawElementID, API_Elem_Head* elem_Head, UInt32 mask );
Parameters
- elem_Head
- identifies the element to draw/show
- mask
- [in] Element mask (from floor plan).
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
elemHead
isnullptr
APIERR_BADID
- The element is not present in the Archicad database.
APIERR_DELETED
- The element is deleted.
For other common API errors see the API Errors document.
Remarks
This function is used to draw/show an element identified by its element header on the floor plan or in the section or detail window. You should fill the guid
field.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Database.h