Returns a reference to the next element of the current database in the order specified by the BTF/STB system.
GSErrCode ACAPI_Database ( APIDb_DrawOrderGetNextID, API_ElemFilterFlags filterBits, API_Elem_Head* elemHead );
Parameters
- filterBits
- [in] element filter attributes (pass as VALUE)
- elemHead
- [out] element reference
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
elemHead
isnullptr
APIERR_NOMORE
- no more element in the list
For other common API errors see the API Errors document.
Remarks
This function is used to get the database elements in the order the server application would draw them onto the display. The loop should be initialized by the APIDb_DrawOrderInit function.
Pass filter bits (AS A VALUE) to skip elements with specific properties; as shown in the example. See more details on this topic at ACAPI_Element_Filter.
Example
API_Elem_Head elem_head; GSErrCode err; err = ACAPI_Database (APIDb_DrawOrderInitID, nullptr, nullptr); while (err == NoError) { err = ACAPI_Database (APIDb_DrawOrderGetNextID, (void *) (Int32) APIFilt_OnActFloor, &elem_head); if (err == NoError) { /* ... */ } } if (err == APIERR_NOMORE) err = NoError;
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Database.h
See Also
APIDb_DrawOrderInit , ACAPI_Element_Filter
ACAPI_Database, API Functions