APIDb_​GetCompoundInfoStringID

Returns the compound info string of the given element.

    GSErrCode ACAPI_Database (
        APIDb_GetCompoundInfoStringID,
        const API_Guid*         elementGuid,
        GS::UniString*          infoString
    );

 

Parameters

elementGuid
[in] the Guid of the element
infoString
[out] the composite info string of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters is nullptr
APIERR_BADID
no element found by the specified Guid
APIERR_BADELEMENTTYPE
element has no info string

For other common API errors see the API Errors document.

 

Remarks

For hotlinked elements the info string is composed of the element’s own info string and the hotlink element’s info strings it placed via.

 

Requirements

Version: API 17 or later
Header: APIdefs_Database.h

 

See Also

API_Elem_Head
APIDb_GetElementInfoStringID
APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkNodeTreeID
APIDb_GetHotlinkInstancesID
ACAPI_Database
API Functions