APIDb_​GetContainingDatabaseID

Obtains the unique ID of database contains the given element.

    GSErrCode ACAPI_Database (
        APIDb_GetContainingDatabaseID,
        const API_Guid*       element,
        API_DatabaseInfo*     dbInfo
    );

 

Parameters

element
[in] The referred element.
dbInfo
[out] The owner database ID.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The guid or dbInfo parameter is nullptr.
APIERR_NOPLAN
There is no open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the ID of owner database of the referred element.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database, API Functions