APIDb_​GetDBUnIdFromGuidID

Returns the old database identifiers from the database GUID.

    GSErrCode ACAPI_Database (
        APIDb_GetDBUnIdFromGuidID,
        API_Guid*       elemSetId,
        short*      userId,
        UInt32*      databaseId
    );

 

Parameters

elemSetId
[in] Unique identifier of the database.
userId
[out] First old identifier.
databaseId
[out] Second old identifier.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
One of the parameters is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function is used to convert the old database identifiers to the new guid.

 

Example


API_DatabaseInfo databaseInfo;
ACAPI_Database (APIDb_GetCurrentDatabaseID, &databaseInfo, nullptr);

UInt32 currentDatabaseId;
short  userId;

ACAPI_Database (APIDb_GetDBUnIdFromGuidID, &databaseInfo.databaseUnId.elemSetId, &userId, &currentDatabaseId);

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

API_DatabaseUnId
APIDb_GetCurrentDatabase, APIDb_GetGuidFromDBUnIdID
ACAPI_Database, API Functions