Returns the drawing scale of the current database.
GSErrCode ACAPI_Database ( APIDb_GetDrawingScaleID, double* scale );
Parameters
- scale
- [out] the drawing scale
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
dScale
isnullptr
For other common API errors see the API Errors document.
Remarks
This function returns the drawing scale of the current database, as each database may have different scale.
Note: for 1:100 drawings 100.0 is returned, for 1:20 drawings 20.0 is returned etc.
For layouts, the return value is always 1.0.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Database.h