Returns the element referred by guid
irrespectively of the current database.
GSErrCode ACAPI_Database ( APIDb_GetElementFromAnywhereID, const API_Guid* guid, API_Element* element );
Parameters
- guid
- [in] The referred element.
- element
- [out] The element.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
guid
orelement
parameter isnullptr
. APIERR_NOPLAN
- There is no open project.
For other common API errors see the API Errors document.
Remarks
This function is used to get an element irrespectively of the current database. This is a useful function because you don’t have to enumerate all database to find the element, switch to it and get the element.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Database.h