APIDb_​GetElementURLRefID

Retrieves the URL reference assigned to an element.

    GSErrCode ACAPI_Database (
        APIDb_GetElementURLRefID,
        API_Elem_Head*      elem_Head,
        API_ElemURLRef*     elemURLRef
    );

 

Parameters

elem_Head
[in] The element the URL was assigned to.
elemURLRef
[out] The URL reference of the element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Any of the parameters are nullptr.
APIERR_BADINDEX
The element is not present in the Archicad database.
APIERR_BADID
The element cannot hold a URL reference.
APIERR_DELETED
The element is deleted.
APIERR_NOUSERDATA
The element didn’t hold a URL reference.

 

Remarks

This function is used to retrieve the URL reference assigned to an element. The same group of elements can hold a URL reference as userdata.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_Elem_Head
API_ElemURLRef
APIDb_SetElementURLRefID
ACAPI_Database
API Functions