APIDb_​GetExtent3DID

Returns the model extent of the current database.

    GSErrCode ACAPI_Database (
        APIDb_GetExtent3DID,
        API_Box3D*     extent3D
    );

 

Parameters

extent3D
the extent box

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
extent3D is nullptr
APIERR_NOPLAN
no open project

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the drawing extent of the actual database, as well as in vertical range. The extent depends on different settings (hidden layers, actual story etc.), always returns the region would be shown in case of a “Fit in Window” command.  

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_Box3D,
ACAPI_Database, API Functions