APIDb_​GetFullDrawingContentBoxID

Returns the full boundary box of an IDF database.

    GSErrCode ACAPI_Database (
        APIDb_GetFullDrawingContentBoxID,
        API_Box*            api_box,
        const API_Guid*     drawingGuid
    );

 

Parameters

api_box
[out] The bounding box of the drawing’s IDF.
drawingGuid
[in] The guid of the drawing contains the IDF.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
The drawingGuid parameter is invalid.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the bounding box of drawing’s IDF.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database, API Functions