APIDb_​GetGISRefID

Returns the GIS reference of the Virtual Building.

    GSErrCode ACAPI_Database (
        APIDb_GetGISRefID,
        API_GISRef*     gisRef
    );

 

Parameters

gisRef
[out] GIS reference associated with the project

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
gisRef is nullptr
APIERR_NOTINIT
There is no GIS reference associated to the current project

 

Remarks

This function is used to get the GIS Reference associated to the Virtual Building.

This data can be accessed via the API only.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISRef
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
ACAPI_Database
API Functions