APIDb_​GetHotlinkNodeID

Returns a hotlink node identified by its guid.

    GSErrCode ACAPI_Database (
        APIDb_GetHotlinkNodeID,
        API_HotlinkNode*     hotlinkNode,
        bool*                enableUnplaced
    );

 

Parameters

hotlinkNode
[in/out] Hotlink node.
enableUnplaced API version 19
[in] True if the search is performed in all hotlink nodes (including cached ones) and false if only in placed ones.
Note that cached but unplaced hotlink nodes are not visible in the Hotlink Manager dialog.
You can list unplaced hotlinks by calling APIDb_GetHotlinkNodesID with enableUnplaced parameter set to true.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
hotlinkNode parameter is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the data of the specified hotlink node.

 

Example

Hotlink-related code samples can be found in the Element_Test example add-on.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkNode
APIDb_CreateHotlinkNodeID
APIDb_ModifyHotlinkNodeID
APIDb_DeleteHotlinkNodeID
APIDb_BreakHotlinkNodeID
APIDb_UpdateHotlinkCacheID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkNodeTreeID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkInstancesID
ACAPI_Database
API Functions