APIDb_​GetHotlinkNodesID

Returns the list of hotlink nodes.

    GSErrCode ACAPI_Database (
        APIDb_GetHotlinkNodesID,
        const API_HotlinkTypeID*     type,
        GS::Array<API_Guid>*         nodeRefList,
        bool*                        enableUnplaced
    );

 

Parameters

type
[in] optional type selector (APIHotlink_Module or APIHotlink_XRef), if this variable is nullptr, all nodes are collected
nodeRefList
[out] the list of hotlink nodes found in the project
enableUnplaced API version 19
[in] True if the search is performed in all hotlink nodes (including cached ones) and false if only in placed ones.
Note that cached but unplaced hotlink nodes are not visible in the Hotlink Manager dialog.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
the nodeRefList parameter is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function returns the hotlink nodes as a list of Guids. The data of a hotlink node can be retrieved with the APIDb_GetHotlinkNodeID function. To explore a nested node hierarchy, use APIDb_GetHotlinkNodeTreeID. In order to get the hotlink instances placed in the project, use the APIDb_GetHotlinkInstancesID function.

 

Example

See the examples section of APIDb_GetHotlinkInstancesID. Further hotlink-related code samples can be found in the Element_Test example add-on.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodeTreeID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkInstancesID
ACAPI_Database
API Functions