APIDb_​GetHotLinkOwnerID

Returns the identifier of the hotlink instance the element belongs to (see API_HotlinkType).

    GSErrCode ACAPI_Database (
      APIDb_GetHotlinkInstancesID,
      const API_Guid  *elemGuid,
      API_Guid        *hotlinkGuid
    );

 

Parameters

elemGuid
[in] The Guid of the element.
hotlinkGuid
[out] The hotlink instance the element belongs to. APINULLGuid means the element is not part of any hotlinks.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Any of the parameters is nullptr
APIERR_BADID
The elemGuid is invalid or the element is deleted.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the identifier of the hotlink (API_HotlinkType) instance the incoming element belongs to.

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkType
APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkNodeTreeID
ACAPI_Database
API Functions