APIDb_​GetHotlinkRootNodeGuidID

Retrieves the Guid of the Hotlink Module type or XRef type hotlink root node.

    GSErrCode ACAPI_Database (
        APIDb_GetHotlinkRootNodeGuidID,
        const API_HotlinkTypeID*     type,
        API_Guid*                    rootNodeGuid
    );

 

Parameters

type
[in] hotlink type selector (APIHotlink_Module or APIHotlink_XRef)
rootNodeGuid
[out] the Guid of the selected root node

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters is nullptr
APIERR_BADID
the type parameter is neither APIHotlink_Module nor APIHotlink_XRef

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the Guid identifier of the root hotlink node of the selected type. This root node is not a real hotlink node, it actually represents the project itself, and can be used as the parent of the main-level hotlinks when the whole structure is requested with the APIDb_GetHotlinkNodeTreeID function.

 

Example

See the examples section of APIDb_GetHotlinkNodeTreeID. Further hotlink-related code samples can be found in the Element_Test example add-on.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkNodeTreeID
APIDb_GetHotlinkInstancesID
ACAPI_Database
API Functions