APIDb_​GetHotlinkSourceStatusID

Returns the mapping table of the proxy elements and the source elements of the given hotlink instance.

    GSErrCode ACAPI_Database (
      APIDb_GetHotlinkSourceStatusID,
      const IO::Location*                      sourceLocation,
      API_HotlinkSourceStatus*                 sourceStatus
    );

 

Parameters

sourceLocation
[in] The source location of the hotlink instance.
sourceStatus
[out] The status of the queried hotlink location.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
There is no plan open.
APIERR_REFUSEDPAR
There sourceLocation is invalid, or it cannot be found.

For other common API errors see the API Errors document.

 

Requirements

Version: API 26 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkType
API_HotlinkSourceStatus, APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkNodeTreeID
ACAPI_Database
API Functions