APIDb_​GetLast3DDefLevelsID

Retrieves the 3D default levels for the construction elems.

    GSErrCode ACAPI_Database (
        APIDb_GetLast3DDefLevelsID,
        const GS::Array<API_ElemTypeID>*     elemIDs,
        GS::Array<double>*                   values
    );

 

Parameters

elemIDs
[in] The elem types for which you want to obtain the 3D default levels.
values
[out] The 3D default levels for the elem types given in the elemIDs array.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Retrieves the 3D default levels for the types passed in the elemIDs array. Possible elem types: Wall, Column, Beam, Symbol, Light, Slab, Roof, Mesh.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database,
API Functions