Returns the local origin of the current database.
GSErrCode ACAPI_Database ( APIDb_GetLocOrigoID, API_Coord3D* locOrigin );
Parameters
- locOrigin
- the local origin
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
locOrigin
isnullptr
APIERR_BADDATABASE
- the query is valid only for the plan, section, detail and 3D window
For other common API errors see the API Errors document.
Remarks
This function is used to get the local origin of the current database. This can be modified by the user by clicking on the User Origin button on the coordinate box.
The value is measured relative to the origin of the virtual coordinate system.
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Database.h