APIDb_​GetMasterLayoutDatabasesID

Returns the list of unique IDs of all master layout databases.

    GSErrCode ACAPI_Database (
        APIDb_GetMasterLayoutDatabasesID,
        API_DatabaseUnId**            databaseUnIds,
        GS::Array<API_DatabaseUnId>*  databaseUnIdArray
    );

 

Parameters

databaseUnIds
[out] The list of master layout database unique IDs. Note this is not handle; it’s the address of a pointer.
databaseUnIdArray API version 22
[out] the array of master layout databases, in a more recent form. Pass the address of an appropriate GS::Array<> to get the result. This parameter has precedence over the other databaseUnIds parameter.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
dbUnIDs is nullptr
APIERR_NOPLAN
the plan database does not exist

For other common API errors see the API Errors document.

 

Remarks

You can use this function to enumerate all master layout databases.

 

Example

See the Example of the APIDb_GetDatabaseInfoID function.

 

Requirements

Version: API 10 or later
Header: APIdefs_Database.h

 

See Also

API_DatabaseUnId
APIDb_GetDetailDatabasesID, APIDb_GetWorksheetDatabasesID, APIDb_GetLayoutDatabasesID
APIDb_ChangeCurrentDatabase, APIDb_GetDatabaseInfoID
ACAPI_Database, API Functions