APIDb_​GetOffsetID

Returns the offset of origin of the virtual coordinate system.

    GSErrCode ACAPI_Database (
        APIDb_GetOffsetID,
        API_Coord*     offset
    );

 

Parameters

offset
the offset of the origin of the virtual coordinate system

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
offset is nullptr
APIERR_BADDATABASE
the command was called for a non-2D window

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the offset of the origin of the virtual coordinate system from the origin of the world coordinate system.

This origin was introduced in Archicad 9 to reduce the inaccuracies, which could happen if the model was far away from the origin of the world coordinate system. This offset is set after a file is opened, if the so called ‘weight point’ of the model is far enough from the origin of the world coordinate system.

After that all coordinates coming from the API are measured from this origin.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

API_Coord
APIDb_GetLocOrigoID
ACAPI_Database
API Functions