APIDb_​GetOwnWindowsID

Returns the ids of the opened windows in an array.

    GSErrCode ACAPI_Database (
        APIDb_GetOwnWindowsID,
        API_WindowTypeID*        windowTypeID,
        GS::Array<API_Guid>*     guid
    );

 

Parameters

windowTypeID
[in] TypeID of the opened windows.
guid
[out] An array of guids of the opened windows.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
There is no open project. The operation cannot be executed without an open project.
APIERR_BADPARS
Incorrect windowTypeID or guid was specified.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database,
API Functions