APIDb_​GetRVMChangeFirstIssueID

Retrieves the issue in which the given change is issued at first.

    GSErrCode ACAPI_Database (
        APIDb_GetRVMChangeFirstIssueID,
        const GS::UniString*             api_changeId,
        API_RVMIssue*                    api_firstIssue
    );

 

Parameters

api_changeId
ID of the change.
api_firstIssue
The first issue in which the given change is issued.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
api_changeId or api_firstIssue is nullptr.
APIERR_BADID
api_changeId does not identify a valid change.
APIERR_GENERAL
Couldn’t get the first issue.

For other common API errors see the API Errors document.

 

Remarks

You are able to get the first issue that the given GS::UniString identified change is issued in.

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

API_RVMIssue
ACAPI_Database
API Functions