Retrieves all changes belong to the given document revision.
GSErrCode ACAPI_Database ( APIDb_GetRVMDocumentRevisionChangesID, const API_Guid* revisionGuid, GS::Array<API_RVMChange>* api_changes );
Parameters
- revisionGuid
- GUID of the document revision.
- api_changes
- The array of the changes.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
revisionGuid
orapi_changes
isnullptr
.APIERR_BADID
revisionGuid
does not identify a valid document revision.APIERR_GENERAL
- Couldn’t get the changes.
For other common API errors see the API Errors document.
Remarks
You are able to get changes contained by the given document revision.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h
See Also
API_RVMChangeACAPI_Database
API Functions