APIDb_​GetRVMElemChangeIdsID

Retrieves the change IDs of the given elem identified by GUID.

    GSErrCode ACAPI_Database (
        APIDb_GetRVMElemChangeIdsID,
        const API_Guid*                 elemGuid,
        GS::Array<GS::UniString>*       api_changeIds
    );

 

Parameters

elemGuid
GUID of the element.
api_changeIds
The array of the change IDs.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
elemGuid or api_changeIds is nullptr.
APIERR_BADID
elemGuid does not identify a valid element.
APIERR_GENERAL
Couldn’t get the change IDs.

For other common API errors see the API Errors document.

 

Remarks

You are able to get change IDs of the given element.

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

API_RVMChange
ACAPI_Database
API Functions