Retrieves all changes belong to the last revision of the given layout.
GSErrCode ACAPI_Database ( APIDb_GetRVMLayoutCurrentRevisionChangesID, const API_DatabaseUnId* inUnId, GS::Array<API_RVMChange>* api_changes );
Parameters
- inUnId
- The unique ID of the layout database.
- api_changes
- The array of the changes.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
inUnId
orapi_changes
isnullptr
.APIERR_GENERAL
- Couldn’t get the layout database.
For other common API errors see the API Errors document.
Remarks
You are able to get changes contained by the last revision of the given layout.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h
See Also
API_DatabaseUnIdAPI_RVMChange
ACAPI_Database
API Functions