APIDb_​GetSubSetID

Retrieves the Subset settings of the given Layout Subset.

    GSErrCode ACAPI_Database (
        APIDb_GetSubSetID,
        const API_Guid*     guid,
        API_SubSet*         subSet
    );

 

Parameters

guid
The guid of the Layout Subset.
subSet
The Subset.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
subSet is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the subset settings of a Layout Subset given by API_Guid. You can create subsets via APIDb_CreateSubSetID
function.

 

Requirements

Version: API 16 or later
Header: APIdefs_Database.h

 

See Also

APIDb_GetSubSetDefaultID
ACAPI_Database
API Functions