Checks whether the curtain wall panel is degenerate.
GSErrCode ACAPI_Database ( APIDb_IsCWPanelDegenerateID, const API_Guid* guid, bool* isDegenerate );
Parameters
- guid
- [in] Curtain wall panel reference.
- isDegenerate
- [out] Is the panel degenerate?
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
guid
orheight
parameter isnullptr
.APIERR_BADID
guid
is invalid or is not a curtain wall panel reference.
For other common API errors see the API Errors document.
Remarks
Curtain Wall element may contain degenerate panel elements (eg. its length is Eps). These elements are not selectable but for technical reasons database must contains them. This function is used to filter these CW panels.
Requirements
- Version: API 12 or later
- Header: APIdefs_Goodies.h
See Also
ACAPI_Goodies,API Functions