Modifies the parameters of a hotlink node.
GSErrCode ACAPI_Database ( APIDb_ModifyHotlinkNodeID, API_HotlinkNode* hotlinkNode );
Parameters
- hotlinkNode
- [in] hotlink node data to be changed
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
hotlinkNode
parameter isnullptr
.APIERR_BADID
guid
ofhotlinkNode
is invalid.
For other common API errors see the API Errors document.
Remarks
This function is used to modify the data of a hotlink node. The node is identified by the guid
member of the hotlinkNode
parameter.
Only the sourceLocation
, ownerId
and userData
parameters can be modified.
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Requirements
- Version: API 12 or later
- Header: APIdefs_Database.h
See Also
API_HotlinkNodeAPIDb_GetHotlinkNodeID
APIDb_CreateHotlinkNodeID
APIDb_DeleteHotlinkNodeID
APIDb_BreakHotlinkNodeID
ACAPI_Database
API Functions