APIDb_​RebuildCurrentDatabaseID

Rebuilds the current database, even it’s associated window is in the background.

    GSErrCode ACAPI_Database (
        APIDb_RebuildCurrentDatabaseID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to rebuild the current database in the background. Only the visible region of the associated window will be updated.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database, API Functions