APIDb_​RefreshElementID

Rebuilds (refreshes) a library part instance.

    GSErrCode ACAPI_Database (
        APIDb_RefreshElementID,
        API_Elem_Head*     elemHead,
        bool*              force
    );

 

Parameters

elemHead
identifies the element to refresh
force New in API 16
force rebuild for GDL based elements (run parameter script).

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
elemHead is nullptr
APIERR_BADINDEX
The element is not present in the Archicad database.
APIERR_DELETED
The element is deleted.

For other common API errors see the API Errors document.

 

Remarks

This function is used to refresh (rebuild) a library part instance identified by its element header on the floor plan or in the section or detail window.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database, API_Elem_Head, API Functions