APIDb_​SetElementURLRefID

Assigns a URL reference to an element.

    GSErrCode ACAPI_Database (
        APIDb_SetElementURLRefID,
        API_Elem_Head*      elemHead,
        API_ElemURLRef*     elemURLRef
    );

 

Parameters

elemHead
[in] The element the URL has to be assigned to.
elemURLRef
[in] The URL reference of the element.

 

Return Values

NoError
The function was completed successfully.
APIERR_BADPARS
Any of the parameters are nullptr.
APIERR_BADINDEX
The element is not present in the Archicad database.
APIERR_BADID
The element cannot hold a URL reference.
APIERR_DELETED
The element is deleted.
APIERR_MOREUSER
The element already holds a URL reference.

 

Remarks

This function is used for assigning a URL reference to an Archicad database element. The same group of elements can hold a URL reference as userdata.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_Elem_Head
API_ElemURLRef
APIDb_GetElementURLRefID
ACAPI_Database
API Functions