Sets GIS reference of the Virtual Building.
GSErrCode ACAPI_Database ( APIDb_SetGISRefID, API_GISRef* gisRef );
Parameters
- gisRef
- [in] The GIS reference to be associated with the project
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
gisRef
isnullptr
Remarks
This function is used to set the GIS reference of the Archicad plan.
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Database.h
See Also
GIS Reference
API_GISRef
APIDb_GetGISRefID
APIDb_ConvertToSIUnitsID
ACAPI_Database
API Functions