Changes the guid of a previously registered window. Useful when replacing already opened windows by reusing their window object.
GSErrCode ACAPI_Database ( APIDb_SetWindowIdID, const API_Guid* pOldGuid, const API_Guid* pNewGuid );
Parameters
- pOldGuid
- Guid of an existing window to be replaced with the new one.
- pNewGuid
- Guid of a non-existing window to replace the old one.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
pOldGuid or pNewGuid
isnullptr
APIERR_WINDNOTEXIST
- No window found with the given guid.
APIERR_WINDEXIST
- There is a window already registered with the new guid.
APIERR_GENERAL
- Any other unexpected error
For other common API errors see the API Errors document.
Remarks
If there is a content validator associated with the old guid, this function will delete it.
This function only works if the window’s type is either APIWind_MyDrawID or APIWind_MyTextID.
Requirements
- Version: API 22 or later
- Header: APIdefs_Database.h
See Also
ACAPI_DatabaseAPI Functions