APIDb_​StopDrawingDataID

Finalizes the direct creation of drawing elements.

    GSErrCode ACAPI_Database (
        APIDb_StopDrawingDataID,
        GSPtr*       idfMem,
        API_Box*     api_boundBox
    );

 

Parameters

idfMem
[out] an opaque data stream containing the drawing database in a serialized form
api_boundBox
[out] optional parameter; if not nullptr then on return contains the bounding box of the created elements

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function finalizes the database started with APIDb_StartDrawingDataID. The returned database can be used to create a drawing element on the layout or in the model; pass the idfMem pointer in the drawingData member of API_ElementMemo.

 

Example

See the Example section of APIDb_StartDrawingDataID.

 

Requirements

Version: API 10 or later
Header: APIdefs_Database.h

 

See Also

API_Box
APIDb_StartDrawingDataID
ACAPI_Database
API Functions