APIDb_​Switch3DSightID

Switches between different 3D databases.

    GSErrCode ACAPI_Database (
        APIDb_Switch3DSightID,
        API_3DSightID     newSight
    );

 

Parameters

newSight
The ID of the sight (as value!)

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Incorrect sight ID was passed.

For other common API errors see the API Errors document.

 

Remarks

This function is used to switch between the 3D database behind the real 3D window and 3D database behind the API (the 3D information for an element is coming from the floor plan).
The switch usually takes no time unless the database doesn’t exist or was deleted; in these cases the database is rebuilt.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database, API_3DSightID, API Functions