APIDb_​UpdateHotlinkCacheID

Updates the cache of the given hotlink node.

    GSErrCode ACAPI_Database (
        APIDb_UpdateHotlinkCacheID,
        const API_Guid*                hotlinkNodeGuid,
        API_HotlinkCacheGenerator*     hotlinkCacheGenerator
    );

 

Parameters

hotlinkNodeGuid
[in] guid of the hotlink node
hotlinkCacheGenerator
[in] optional cache content generator object

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
hotlinkNodeGuid parameter is nullptr
APIERR_BADID
hotlinkNodeGuid is invalid

For other common API errors see the API Errors document.

 

Remarks

This function is used to update the cache of a hotlink node.

If the hotlink content is supposed to be generated by the add-on, you need to pass a generator object. The GenerateCacheContentForHotlinkNode method of API_HotlinkCacheGenerator must be implemented to create the new (updated) content of the specified hotlink cache. When this method is called back from the APIDb_UpdateHotlinkCacheID function, the standard element and attribute creator functions (like ACAPI_Element_Create and ACAPI_Attribute_Create) are redirected to create elements and attributes into the hotlink cache database, rather than the project database.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

See the examples section of API_HotlinkCacheGenerator. Further hotlink-related code samples can be found in the Element_Test example add-on.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkNode
API_HotlinkCacheGenerator
APIDb_GetHotlinkNodeID
APIDb_CreateHotlinkNodeID
APIDb_ModifyHotlinkNodeID
ACAPI_Database
API Functions