APIDo_​CancelCurtainWallID

Cancel changes in Curtain Wall editing mode.

    GSErrCode ACAPI_Automate (
        APIDo_CancelCurtainWallID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
ARCHICAD is not in Curtain Wall editing mode.

For other common API errors see the API Errors document.

 

Remarks

Curtain Wall is editable only in 3D editing mode. You are able to cancel changes via this function.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Automate, APIDo_OkCurtainWallID, APIDo_EditCurtainWallID, API Functions