APIDo_​EditCurtainWallID

Change to Curtain Wall editing mode.

    GSErrCode ACAPI_Automate (
        APIDo_EditCurtainWallID,
        API_Guid*     guid
    );

 

Parameters

guid
[in] guid of the curtain wall open for editing in 3D.

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
Already it’s in editing mode.
APIERR_BADPARS
guid is invalid.

For other common API errors see the API Errors document.

 

Remarks

Curtain Wall is editable only in 3D editing mode. You are able to go to this state via this function.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Automate, APIDo_CancelCurtainWallID, APIDoOkCurtainWallID, API Functions