Change to Hierarchical Elem (Curtain Wall, Stair, Railing, Beam, Column) editing mode.
GSErrCode ACAPI_Automate ( APIDo_EditHierarchicalElemID, API_Guid* guid );
Parameters
- guid
- [in]
guid
of the hierarchical elem (curtain wall, stair, railing, beam, column) to be open for editing in 3D.
Return Values
NoError
- The function has completed with success.
APIERR_REFUSEDCMD
- It is already in hierarchical editing mode.
APIERR_BADPARS
guid
is not a valid curtain wall, stair, railing, beam or column guid.
For other common API errors see the API Errors document.
Remarks
Switch to 3D editing mode of a hierarchical elem (curtain wall, stair, railing, beam, column).
This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Automate.h