Resets and loads the active libraries.
GSErrCode ACAPI_Automate ( APIDo_LoadLibrariesID, const GS::Array<API_LibraryInfo>* activeLibs );
Parameters
- activeLibs
- [in] Specification of the active library folders.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
activeLibs
isnullptr
For other common API errors see the API Errors document.
Remarks
This function is used to perform a Load Libraries command in the server application.
The active libraries will be dropped, and the new library set will be loaded. Note that BIMcloud / BIM Server Libraries cannot be loaded using this method.
Example
GS::Array<API_LibraryInfo> lip; API_LibraryInfo li; GSErrCode err; li.location = IO::Location ("H:\\Archicad 8.1\\Archicad Library 8.1\\Background Images 8"); lip.Push (li); li.location = IO::Location ("H:\\Archicad 8.1\\Archicad Library 8.1\\Textures 8"); lip.Push (li); err = ACAPI_Automate (APIDo_LoadLibrariesID, &lip); if (err == NoError) ACAPI_WriteReport ("APIDo_LoadLibrariesID ...OK", false);
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Automate.h