APIDo_​PublishID

Publishes a publisher set.

    GSErrCode ACAPI_Automate (
        APIDo_PublishID,
        API_PublishPars          publishPars,
        GS::Array<API_Guid>*     selectedLinks
    );

 

Parameters

publishPars
[in] Control parameters; the guid member identifies the set to be published.
selectedLinks
[in] Optional parameter; publish only these items.

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
The function is called from notification level.
APIERR_BADINDEX
The guid in publishPars is invalid.
APIERR_BADPARS
publishPars is nullptr, or no open project.

For other common API errors see the API Errors document.

 

Remarks

This function publishes the given publisher set.

To get more details on the parametrization refer to the API_PublishPars structure.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

 

Example

Please see the PublishTest() function in the Navigator_Test example.

 

Requirements

Version: API 12 or later
Header: APIdefs_Automate.h

 

See Also

API_PrintPars
API_NavigatorSet
APINavigator_GetNavigatorSetID
ACAPI_Automate, API Functions