APIDo_​QuitID

Terminates the server application.

    GSErrCode ACAPI_Automate (
        APIDo_QuitID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
the function is called from notification level

For other common API errors see the API Errors document.

 

Remarks

This function is used to terminate the server application.

It cannot be called from notification level; the command is refused if other addons are running. Calling this function may notify other addons on the event. The caller addon does not get any notification. See the Notification Manager for further details.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

Not for public usage.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Automate, API Functions