APIDo_​RebuildID

Rebuilds the content of the current window.

    GSErrCode ACAPI_Automate (
        APIDo_RebuildID,
        bool*     doRebuildAndRegenerate
    );

 

Parameters

doRebuildAndRegenerate
[in] Performs a rebuild and regenerate operation instead of a simple rebuild. Optional; considered false (i.e. rebuild only) if omitted.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
no open project
APIERR_BADDATABASE
the current window and the active database don’t match

For other common API errors see the API Errors document.

 

Remarks

This function is used to rebuild the content of the current (front) window. The effect is the same as if the user chose the Rebuild menu command with or without holding the Option (Alt) key.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example


GSErrCode   err;
bool        regenerate = true;      /* do rebuild & regenerate */

err = ACAPI_Automate (APIDo_RebuildID, &regenerate, nullptr);

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Automate, API Functions