User supplied callback function for handling changes in elements.
typedef GSErrCode APIElementEventHandlerProc ( const API_NotifyElementType* elemType );
Parameters
- elemType
- [in] This structure contains the various parameters identifying the element the notification is for.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This is the function which will be called when your add-on attached an observer to an element with ACAPI_Element_AttachObserver, i.e. you are interested in changes to an element. This is a common entry point to your add-on for all observed elements; the element in question is passed in the elemType
parameter. For an example, see ACAPI_Notify_CatchNewElement.
The meaning of the notification parameters are desrcribed at the API_NotifyElementType structure.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h
See Also
API_NotifyElementType
ACAPI_Element_AttachObserver
ACAPI_Notify_CatchNewElement
API Functions